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Think about what kinds of things around you use optical sensors. Also consider how the optical sensors control those objects.

Use a black felt-tip pen to draw a course line 20 mm wide on a sheet of white paper. Try running the robot along the course.

What kinds of things? How do they use sensors? What do they do?

Optical sensors

Make your own tracing course

Use the included course sheet for line tracing experiments to verify that the tracing robot functions properly.

・ How the optical sensors work

・ How the tracing robot works

・ How to use Line Tracing Mode

Press on the sensor until you hear a beep.

Switch ON

● The robot does not move
 → The robot may still be in Programming Mode. Switch off the power. Press on the sensor, then switch on the power again.

 → If your finger is dry, the sensor will not detect your touch. Moisten your finger with water.

 →

● Line Tracing Mode does not start

● The tracing robot does not follow the line
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１. Operate the robot in Line Tracing Mode

Troubleshooting

Finished my 
course.

Check!

Finished 
the course.

Check!

White

Black

1

The optical sensors measure the intensity of light reflected from the 
paper course. Black areas reflect light of a different intensity to white 
areas. The robot can therefore use its optical sensors to determine 
where it is on the course.

When the right-hand sensor detects black, the robot determines that the 
course leads to the right. It stops the right motor, allowing the left motor 
to turn the robot to the right. (The opposite occurs when the left-hand 
motor detects black.) When both sensors detect the black finish line, the 
robot determines that the course is about to end, and stops both motors.

Place the robot at the start position. Align the black course line with the 
center of the main body.
(Make sure the sensors are not directly over the black line.) 
Rest one finger on the touch sensor and switch on the power.
You will hear a long beep when Line Tracing Mode activates.
(Keep your finger on the touch sensor until the beep stops.) 
Lift your finger off the touch sensor. You will hear a short beep and the 
robot will start to move.
See if the robot is able to follow the line and stop at the right spot.

The robot uses optical sensors to detect black course lines when in Line Tracing Mode. The robot's 
movement is easily affected by its surroundings. If the room is too bright, course line detection may 
be impaired. Close all curtains and operate under controlled lighting conditions. Make sure there are 
no shadows cast on the course. They could affect the operation of the sensors.

If one of the sensors detects black, the tracing robot turns 
in the direction of that sensor. The robot is not able to 
react to sudden changes in direction or curves with a 
radius less than 100 mm. Remember these facts so that the 
robot does not leave the course.
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Time Optical sensorData Transfer Area Motion Commands

Program Control Tracer
File (F) Edit (E) Run (R) Help (H)

Right turnLeft turn

Pause

Go 2.0 Sec. 3.0 Sec.

4.0 Sec. 5.0 Sec. 6.0 Sec.

7.0 Sec. 8.0 Sec. 9.0 Sec.

Both BothOne side

One side Left side Left side

Right side Right side Sensor calibration
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1.0 Sec.

① ② ③

④ ⑤ ⑥

⑦ ⑧ ⑨

1 2 3 4 5 6 7 8

Routine Subroutine 1 Subroutine ２

Insert the CD-ROM into your computer's CD/DVD drive. Access the CD/DVD drive from My Computer, then drag-and-drop 

the 　　　 icon onto the desktop.

Visit the Artec website (http://www.artec-kk.co.jp/en/pct) and download the control software to your desktop. 
Double-click the 　　 　icon to launch the software.

Exiting the control software

Control Software Icons
Basic Icons

Advanced Icons

Access the File menu and select <Exit> to quit the control software.

● Installing the control software from the Internet

Programming Screen
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Date Grade Class Student no. NAME

● Installing the control software from the CD-ROM

2. Use the software to create a control program for the robot

Programming Area

Programming Icons

D
ata Transfer A

rea
Launched the control 
software 
successfully.

Check!

Understood what 
the icons mean.

Check!

Exited the software 
successfully.

Check!

● Configure icons You can edit values for the time icons and repeat icons. Double-click an icon, then enter a new value in the settings 
window that appears. Click OK to apply the change.

Motion Icons Time Icons Optical Sensor Icons
Go

Right turn

Left turn

Pause

Until both sensors 
detect white color

Until one of the 
sensors detects 
white color

Until both sensors 
detect black color

Until one of the 
sensors detects 
black color

Until the left sensor 
detects white color

Until the right 
sensor detects 
white color

Until the right 
sensor detects 
black color

Until the left sensor 
detects black color

Start repeating a 
part of a program 
from this point. 

Insert a specific 
action sequence 
into your program.

Pause the program.
Use the touch sensor 
to resume operation.

Insert a specific 
action sequence 
into your program.

Indicates when 
and where to 
stop repeating.

Time setting
You can set times 
from 0.5-25.5 seconds.
The minimum 
unit is 0.1 seconds.

Cycle setting
You can set 1-255 repeats.
The minimum unit is 1.

2

Program
Control Tracer

Program
Control Tracer

This is a screenshot of the programming screen.
Simply drag-and-drop icons into the programming area to 
create a routine for the robot. You can add 24 icons 
under the Routine tab and 8 icons under each of the 
Subroutine tabs.
When you have finished designing your program, simply 
send it to the robot via optical communication from the 
data transfer area. The robot will carry out the actions 
indicated on the icons in the order you place them.

Program Control Tracer
File (F) Edit (E) Run (R) Help (H)

メニュー転送位置
Open (O)
save as (S)

exit (X)

005 times
repeat Touch sensorSubroutine

１
Subroutine

２Repeat
start

Both

One side

Both

One side

Left side

Left side

Right side

Right side

Sensor calibrationGo

Right turn

Left turn

Pause

1.0 sec

①

9.0 sec

⑨

There are nine 
time setting icons.
By default, time 
periods from 1.0 
to 9.0 seconds 
are allocated to 
the icons.
Double-click any 
icon, then set the 
time period from 
the pop-up menu. 
You can select 
time periods from 
0.5 to 25.5 
seconds, in 0.1 
second 
increments.

Place these icons to create routines that use the optical sensors. (For 
more information, refer to section 6, "Utilize the optical sensors" on page 
7.) The sensors use the light intensity of the starting point as a reference 
value. Light intensity values the same or higher than the reference value 
are considered white; values below are considered black. 

Cycle setting

Cycles



How to use the control software

Creating control programs (routines)

Useful Functions

3. Use the software to create a control program for the robot

Added icons 
to the routine.

Check!

Edited icons 
in the routine.

Check!

Understood useful 
functions.

Check!

Editing icons in your routine
Right-click on the icon you want to 

change to bring up the Edit menu.

Add repeat icons to Row A. Add motion, subroutine, and touch sensor 

icons to Row B. Add time icons and sensor icons to Row C. 

Drag-and-drop icons into each row to create your program.

Now try it yourself! Add the Go icon to the first column of your routine. 

Time icon ① will automatically be added underneath. To adjust the time 

setting, drag-and-drop a different time icon over ①.

Program Control TracerProgram Control TracerProgram Control TracerProgram Control TracerProgram Control Tracer WorksheetWorksheetWorksheetWorksheetWorksheet Program Control TracerProgram Control Tracer WorksheetWorksheet

Ba
si
c 

A
dv
an
ce
d

Time Optical sensorData Transfer Area Motion Commands

Program Control Tracer
File (F) Edit (E) Run (R) Help (H)

Pause

Go

Right turnLeft turn 6.0 Sec.

7.0 Sec. 8.0 Sec. 9.0 Sec.

Both BothOne side

One side Left side Left side

Right side Right side Sensor calibration
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1.0 Sec.

①

2.0 Sec.

②

3.0 Sec.

③

4.0 Sec.

④

5.0 Sec.

⑤ ⑥

⑦ ⑧ ⑨

1 2 3 4 5 6 7 8

Routine Subroutine 1 Subroutine 2

Row B
Row A

Row C

Go

Go

1.0 Sec.

①

2.0 Sec.

②

Drag & Drop

Delete (X)

Delete a column (Y)
Add a column (Z)

Edit menu 

1 2 3 4 5

Routine Subroutine 1 Subroutine 2

Go

1.0 Sec.

①

Right turn Left turn

3.0 Sec.

③

2.0 Sec.

②

"Delete" removes an icon.

"Delete a column" 
removes a column, pulling the 
remaining columns to the left.

"Insert a column" 
puts a new column in 
between two existing ones.

Go

4.0 Sec.

④
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1 2 3 4 5

Routine Subroutine 1 Subroutine 2

Go

1.0 Sec.

①

Left turn

3.0 Sec.

③

Go

4.0 Sec.

④

1 2 3 4 5

Routine Subroutine 1 Subroutine 2

Go

1.0 Sec.

①

Left turn

3.0 Sec.

③

Go

4.0 Sec.

④

1 2 3 4 5

Routine Subroutine 1 Subroutine 2

Go

1.0 Sec.

①

Right turn Left turn

3.0 Sec.

③

2.0 Sec.

②

Go

4.0 Sec.

④

File → Open: Opens previously saved data. 
File → Save As: Saves created program.

Edit → Reset: Delete all icons added to your program.

Edit → Reset times: Returns each time icon to its original setting.

Edit → Display text: Shows a readable text version of the program 
　　　  you created.

● Text example

1 2 3 4 5 6 7 8

Routine Subroutine 1 Subroutine 2

Go GoTouch sensorSubroutine

１
Right turn Left turn

Sensor calibration 5.0 Sec.

⑤

Both

●Example routine
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Start motion sequence

Basic motion
01. 　Repeat start: NO 　　　　　　　　Calibrate the sensor
02. 　Repeat start: NO 　Go　　　　　　5.0 S
03. 　Repeat start: YES　Right turn　　1.0 S
04. 　Repeat start: NO 　Subroutine１ 

Subroutine 1

Basic motion
05. 　Repeat start: NO 　Touch senser 
06. 　Repeat start: NO 　Go　　　　　　6.0 S
07. 　Repeat start: NO 　Left turn 　　4.0 S

End motion sequence

3



Transferring a control program to the Program Control Tracer

Transferred a control 
program to 
the robot.

Check!

How to transfer a control program
Add icons to the routine. After creating your program, transfer it to the Program Control Tracer.

１. Remove the optical sensor from 
　  the Program Control Tracer.

3. Access the Run menu, then click "Send control program".

4. The Data Transfer dialog box appears. Hold the optical sensor to 
　 the data transfer area, switch on the power, and wait for the long beep to end.

5. Click "OK" to start the data transfer.

２. Hold the optical sensor to the data transfer area. 

Press down the rivet collar and remove the rivet from 
the back of the sensor board.

Position the sensors right above the white circles in the black squares. 
If the sensors and circles are not aligned, adjust the placement of the 
black squares using the bar at the bottom of the data transfer area.

６. When data transfer is complete, you will hear a long beep before being returned to the programming screen.
　 ★ There will be no beep if data transfer fails.
7. Reattach the optical sensor circuit board to the robot body.
8. To execute the control program, tap the touch sensor on the main circuit board with your finger. 
9. To repeat the program, tap the touch sensor again. 
10. When you turn the power off, the robot's program memory will be erased.

● Enjoy making many different kinds of control programs for your Program Control Tracer!

The Program Control Tracer transmits data to a computer via optical communication. Glossy 
monitors, inappropriate color depth settings, and glare from the sun or other lighting may 
adversely affect data transmission. Close all curtains to prevent light from entering the room and 
falling on the monitor. You may find it helpful to use cardboard or something similar to shade the 
optical sensor from external light while holding it to the monitor.
If the contrast is too high, refer to the monitor's documentation and change the setting. If 
problems occur with data transfer even after adjusting the operating environment and display 
settings, use the optical sensor protective cover provided in the instructions. For best results, 
attach the cover to the cardboard before use.

● Example routine ★ 

Problems during 
data transfer... 

Prepare the included optical sensor 
protective cover.
Use the rivet collar to attach the 
protective cover to the sensor, as 
shown.
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1 2 3 4 5

Routine Subroutine 1 Subroutine 2

Go

1.0 Sec.

①

Right turn Right turnLeft turn

3.0 Sec.

③

2.0 Sec.

②

Go

4.0 Sec.

④

5.0 Sec.

⑤
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Data Transfer Area

Program Control Tracer

Transfer (T)
File (F) Edit (E) Run (R) Help (H)

You will hear a short beep every 
time the Program Control Tracer 
receives data.
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Forward movement

How to use the course sheet

4. Measure the movement of the Program Control Tracer

5. Complete an experiment course

Gathered data about 
forward 
movement.

Check!

Gathered data on 
left and right 
turns.

Check!

0 1010
2020

3030

40
40

50

50

60

60

70

70

80
90

80
90

The robot's movement is controlled by two motorized gearboxes. The performance of individual gearboxes may vary. If the 
two gearboxes provide different performance, the robot may veer slightly as it travels straight. Performance is also affected by 
the state of the batteries. Use the gauges provided to periodically measure the robot's movements, and make necessary 
adjustments with the control software.

Use the gauge on page　　 for measurement. Create programs to test how long it takes the robot to move forward a certain 
distance and how far it can travel over a given time period. Record your results in the table on page 　　.

Place the Program Control Tracer on the START space, and create programs to make it reach the goal in various ways. Fill in 
each table to record what routines you used to clear the courses.

Left and right movement
Use the gauge on page 　　 for measurement. Create programs to test how long it takes the robot to change direction and 
how much it turns over a given time period. Record your results in the tables on page 　　.

1 2 3 4 5 6 7 8 9

10

111213141516171819

11

11

12

12
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Date Grade Class Student no. NAME

Course 6 cleared.

Check!

Course 1: Start → Goal A

Course 2: Start → Turn A → Goal B 

Course 3: Start → Turn C → Goal B

Course 4: Start → Turn A → Turn B → Goal B

Course 5: Start → Turn A → Turn B → Goal A → Turn C → Goal B 

Course 6: My own course
Create your own course and try to clear it.
Start →

Check! Course 1 cleared.

Check! Course 5 cleared.

Check! Course 4 cleared.

Check! Course 3 cleared.

Check! Course 2 cleared.

1 2 3 4 5 6 7 8
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7

This function allows you to repeat a portion of your control program. Bracket the desired portion between 　　 icons on Row 
A. Place a Repeat icon at the beginning and a 　　 icon at the end of the portion to be repeated. For information about 
changing the number of repeat times, refer to the "Configure icons" section on page 2.

To create a program that uses the optical sensors, 
drag-and-drop the 　　 icon onto the first column in row C.

When the above program is executed, the sensors will calibrate by measuring 
the light intensity of the start point. They use this measurement as a reference value. 
Light intensity values the same or higher than the reference value are considered white; 
values below are considered black. The larger the difference between black and white, 
the easier it is for the sensor to detect the course line.

6 . Utilize the optical sensors 

7. Advanced Operations
How to use the repeat function

① The robot calibrates its sensors, then it proceeds to the next step in the program.

② The robot goes straight until both sensors detect black, then it proceeds to the next step.

③ The robot keeps turning right until both sensors detect white, then it proceeds to the next step.

④ The robot keeps turning left until both sensors detect black, then it proceeds to the next step.

⑤ The robot goes straight until it detects white, then the program ends.

How to use subroutines

Example routine with repeat commands between the second and fifth columns

★ Include at least two 
　 commands when using 
　 the repeat function.

①

②

④

Starting point

⑤

③

Program Control TracerProgram Control TracerProgram Control TracerProgram Control TracerProgram Control Tracer WorksheetWorksheetWorksheetWorksheetWorksheet Program Control TracerProgram Control Tracer WorksheetWorksheet

● Example routine

Row B
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Go GoRight turn Left turn

Sensor calibration Both BothBoth Both

Row B
Row A

Row C

1 2 3 4 5 6 7 8

Routine Subroutine 1 Subroutine 2

Go GoRight turn Right turnLeft turn
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Understood how to 
program the 
optical sensors.

Check!

Understood how to 
use the repeat 
function.

Check!

Understood how to 
use subroutines.

Check!

Subroutines are mini sequences that you can insert into your routine. Click the Subroutine tab to display the programming 
area. Add icons in the same manner as when creating routines. (The repeat, subroutine, and touch sensor icons are not 
available for subroutines.) When you finish placing icons on the Subroutine, go back to the Routine tab. Define where to 
execute the subroutine by placing the Subroutine 1 icon in Row B. (Create Subroutine 2 in the same manner.)
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Routine Subroutine 1 Subroutine 2

Go GoRight turn Right turnLeft turn

● Example subroutine
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Routine Subroutine 1 Subroutine 2

Go GoRight turn Right turnLeft turn Left turnSubroutine

１
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Create your own maze!

8. Make your own obstacle course!
Maze Escape

Example course

Measure how long it takes 
the robot to escape from the maze.

sec.

How to use the Touch Sensor icon
The Touch Sensor icon pauses the current routine. Add the icon to Row B wherever you 
wish to use the touch sensor. Tap the touch sensor to resume the routine.
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Date Grade Class Student no. NAME

Understood how 
to use the 
touch sensor.

Check!

Maze cleared.
Check!

● Example routine

Row B
Row A

Row C

1 2 3 4 5 6 7 8

Routine Subroutine 1 Subroutine 2
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Go GoRight turn Right turnLeft turn Left turnTouch sensor
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9

Design your course below.

9. Free course
Create and clear your own course, utilizing everything you have learned about the Program Control Tracer's functions.
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Free course cleared.

Check!
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Date Grade Class Student no. NAME10

10. Review

● What have you learned about Line Tracing Mode?

● Write about the movements of the robot and the programs that employ them.

● Think about the world around you. What kinds of things feature control systems, and what kinds of systems are they?

● Write down your overall impressions, based on your experiences controlling the robot. 
　 What control techniques do you think would be useful to have?
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Measuring gauge for forward movement

①

②

③

④

⑤

⑥

⑦

⑧

⑨

⑩

⑪

⑫

⑬

⑭

⑮

⑯

⑰

⑱

⑲

⑳

Set time (sec.) Travel distance (mm)

1

0

2
3
4
5
6
7
8
9

10

11
12
13
14
15
16
17
18
19

20

21
22
23
24
25
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Date Grade Class Student no. NAME

Measuring gauge for left/right turns

Right turn

Left turn

①

②

③

④

⑤

⑥

⑦

⑧

⑨

①

②

③

④

⑤

⑥

⑦

⑧

⑨

Set time (sec.) Turning angle

0
10

10
20

20
30

30

40
40

50
50

60
60

70
70

80 90
80 90

Set time (sec.) Turning angle

Right turn

Left turn
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